Hi there,

I've got a 8440 that I'm wanting to put live on to our system and can get it up and working on wifi and actually setup fine, but was going to try and get it updated with all the firmware updates that are available. If I log into the web portal and ask it to check the server it fails (I'm assuming - this is because it's looking at polycom instead of spectralink as is now). 

 

I've set up a ftp server and tried to put the files and folders in structure for what I think should updated and it appears as a green version and i can tell it to apply however it fails. 

 

I can see in one of the logs that there is the line - "Download of master configuration file failed" so I'm assuming I'm doing something not quite right. I've tried to follow everything as I can see but I guess I'm going wrong somehwere. Can someone offer any advice at all in regards to what could be going wrong?

 

Thanks

Forums: 

Comments (3)

  • anon
    John Beaman

    Check your download path. The phone is not able to find the firmware where the firmware.xml file says it is. Here is my firmware.xml:

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <PHONE_IMAGES>
    <REVISION>
    <PHONE_IMAGE>
    <VERSION>4.8.0.2004</VERSION>
    <PATH>http://www.mysite.com/Spectralink8400/4.8.0.2004</PATH>
    </PHONE_IMAGE>
    </REVISION>
    <REVISION>
    <PHONE_IMAGE>
    <VERSION>4.10.0.2005</VERSION>
    <PATH>http://www.mysite.com/Spectralink8400/4.10.0.2005</PATH>
    </PHONE_IMAGE>
    </REVISION>
    </PHONE_IMAGES>

    Then, in the root folder of my FTP server I have created a folder called Spectralink8400. In that folders I have sub-folders for each version of the firmware available. Each sub-folder contains:
    sip.ld
    sip.ver
    slnk84xx.sip.ld

    Jul 17, 2015
  • anon
    Jerry

    you may need to shut down the firewall on your ftp server for the update

    Apr 05, 2016